IntelliJ에서 Kotlin 버전 지정하기

안드로이드 스튜디오에서도 Kotlin을 쓸 수 있지만, 단순히 몇가지 문법과 기능들만 테스트해보고 싶을 때는 프로젝트를 따로 만드는 것이 편리하다. 현재 작업 중인 프로젝트에서 잠깐 코드를 작성했다가 지우는 방법도 있겠지만, 빌드가 가능한 상태가 되기까지 해야할 작업이 많이 남아있거나 하는 경우도 있으므로 인텔리제이에서 프로젝트를 따로 만들어두는 것이 좋다.

인텔리제이에서 Kotlin 프로젝트를 생성해서 사용하고 있었는데, 코루틴 최신 라이브러리를 추가하고 예제 코드를 작성했더니 1.2에서는 사용할 수 없다는 에러가 나왔다. Kotlin 플러그인은 1.3.11로 업데이트했는데 기존 1.2로 지정되어있던 것을 어떻게 바꿔야할지 갑자기 생각이 안났다.

안드로이드 스튜디오에서 Kotlin 버전을 지정할 때는 gradle 파일에서 플러그인 버전을 변경하는 식으로 했었는데 오랜만에 인텔리제이에서 하려니 막막한 느낌이 들었다.

당연하게도 Preferences에서 변경해주면 된다; (Java SDK 버전 지정하듯이…)

Leave a Comment

Your email address will not be published.